cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Curdt <tcu...@dff.st>
Subject Re: HEAD is broken (was: RE: strange problem with HEAD)
Date Mon, 03 Dec 2001 14:05:37 GMT
On Mon, 3 Dec 2001, Berin Loritsch wrote:

> Torsten Curdt wrote:
>
> > I tried now 3 different machines and 3 different servlet engines...
> > ...so I doubt this is just me.
> >
> > Unfortunately I wasn't able to track it down. Berin, maybe you
> > have an idea? Looks like it is realated to the avalon framework
> > jar.
>
>
> Hmm.  I updated the jars in HEAD, and asked for people to give feedback
> because when I tested it here, it worked.  What exactly is the issue?

Ok, this is what I get when I deploy a fresh cocoon.war with catalina
when cocoon should come up.

> I get a ServletException with Root Cause:
>
> javax.xml.parsers.FactoryConfigurationError:
>     Provider for javax.xml.parsers.SAXParserFactory cannot be found
>         at javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:141)
>         at org.apache.avalon.framework.configuration.DefaultConfigurationBuilder.<init>(DefaultConfigurationBuilder.java:38)
>         at org.apache.cocoon.servlet.CocoonServlet.initLogger(CocoonServlet.java:578)
>         at org.apache.cocoon.servlet.CocoonServlet.init(CocoonServlet.java:162)
>
> In the xml-apis.jar there is both the FactoryConfigurationError and the
> javax.xml.parsers.SAXParserFactory. As well as there is xerces in WEB-INF/lib

Give me a minute and I'll post the exception from the other machine,
too....

It was alway something inside the DefaultConfigurationBuilder
--
Torsten


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message