cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sam Ruby" <ru...@us.ibm.com>
Subject Re: [GUMP] Build Failure - Cocoon2
Date Wed, 21 Nov 2001 14:15:17 GMT
Berin Loritsch wrote:
>
> :)  Seriously, we are gearing up for a release of Framework, then Excalibur.
> If you want to upgrade, you must upgrade both--and be prepared to do it again
> when the final is done.  This will also allow you to migrate toward LogEnabled
> instead of Loggable.

If this were done, and a Cocoon2 release were made shortly thereafter, then
cocoon users would be prevented from using the latest released version of
Excalibur.

Even if Excalibur were released (soon before, concurrent, or even soon
after), using Cocoon2 with any other components which requires excalibur
would generally require those components to work with exactly that one
specified release of Excalibur, or deal with a more complex configuration
task involving various levels of classpath hell.

I am a big proponent of deprecation and generally request that any dot
release of a project maintain at least backwards compatibility to the
previous release of the same project.  Meanwhile, I personally try to avoid
introducing deep dependencies on projects which do not observe such
policies.

Something to consider.

- Sam Ruby


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message