cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <>
Subject Re: [GUMP] Build Failure - Cocoon2
Date Mon, 19 Nov 2001 16:04:29 GMT
Gerhard Froehlich wrote:

>>>is the "old" version of excalibur active? Because
>>>I can compile the latest checkout!
>>>If yes, shall we switch to the new version and change
>>>the implementation?
>>Before you include the newest version, the Avalon team needs
>>to finish the Framework release (allowing namespaces in
>>configs and allowing us to migrate to the new LogEnabled

> I didn't want to include the newest version. I don't know why,
> but the newest version is already in the 2.1 branch....

What you are saying is a CVS snapshot is in 2.1 branch?  :/

>>This process includes THOROUGHLY testing Excalibur due to
>>the two changes in framework.  When we are satisfied that
>>the two changes do not adversely affect existing projects,
>>we will release Avalon Framework.

> But then I don't understand why it's not in the ScratchPad?

Which "it" are you talking about: configuration, logging, or
PriorityQueue?.  The only one that would be elegible for
scratchpad is PriorityQueue as it is the only one in the list
that is from Excalibur.  The namespace support is a new added
feature--however, you never want to violate regression testing.
The logging abstraction (i.e. Avalon Framework projects are no
longer directly tied to LogKit for logging) is a new feature.
Before an official 4.1 release, we need to make sure that it
passes our standards.


"Those who would trade liberty for
  temporary security deserve neither"
                 - Benjamin Franklin

To unsubscribe, e-mail:
For additional commands, email:

View raw message