cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Haul <h...@dvs1.informatik.tu-darmstadt.de>
Subject Re: Compilation problems was RE: [Fwd: freshmeat project listing for Cocoon]
Date Fri, 23 Nov 2001 13:21:31 GMT
On 23.Nov.2001 -- 01:43 PM, giacomo wrote:
> On Fri, 23 Nov 2001, Carsten Ziegeler wrote:
> > > From: giacomo [mailto:giacomo@apache.org]
> > > Big no. After a clean checkout of the HEAD I was able to compile
> > > but building the docs failed havily.
> > >
> > > Could someone fix that more familiar with it than I am? I think it has
> > > to do with the DTD resolver whcih cannot find the DTDs requested during
> > > the build of the docs (even if I've sound them to be there where it
> > > complains wouldn't be there).
> > a "build docs" works perfectly here. Hm
> 
> Lucky you. This is what I get on a clean checkout from HEAD:
> 
> INFO    10065   [        ] ():   Link translated:
> graphics/Todo-label_over.jpg
> Resolved public: -//APACHE//DTD Documentation V1.0//EN
> 
> file://home/giacomo/cvs/xml-cocoon2/build/cocoon/documentation/resources/entities/document-v10.dtd
> Failed to create InputSource:
> file://home/giacomo/cvs/xml-cocoon2/build/cocoon/documentation/resources/entities/document-v10.dtd
> ERROR   10065   [        ] (): Could not read resource
> file:/home/giacomo/cvs/xml-cocoon2/build/cocoon/documentation/xdocs/plan/index.xml
> org.xml.sax.SAXParseException: File
> "file:/home/giacomo/cvs/xml-cocoon2/build/cocoon/documentation/dtd/document-v10.dtd"
> not found.

For me "build docs" fails to find the catalogs, too. 

I *think* it should be "file:///home/g..." (3 x '/'). If you point
e.g. w3m or mozilla to the modified URL it will find the file.

For cocoon_20_branch applying

--- documentation/cocoon.xconf.orig  Mon Nov 19 11:12:58 2001
+++ documentation/cocoon.xconf     Thu Nov 22 14:53:48 2001
@@ -101,7 +101,7 @@

   -->
   <resolver class="org.apache.cocoon.components.resolver.ResolverImpl">
-   <parameter name="catalog" value="/resources/entities/catalog"/>
+   <parameter name="catalog" value="//resources/entities/catalog"/>
    <parameter name="verbosity" value="2"/>
   </resolver>

resolves :-) the issue for me. Alternatively, value="resources..."
works OK as well. Looks like the URL is not composed correctly.
BTW: this is linux with sun jdk 1.3.1

	Chris.

-- 
C h r i s t i a n       H a u l
haul@informatik.tu-darmstadt.de
    fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message