cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reinhard Pötz <reinhard_po...@gmx.net>
Subject Bug in the context:/ - protocol?
Date Sun, 14 Oct 2001 14:32:43 GMT
I use the following pipeline in the root sitemap of cocoon - everything
works fine.

If I want to use it in a sub-sitemap I always get an error because the
action cannot access the file named in <map:parameter name="descriptor"
value="docs/test_form.xml"/>.

I tried it with <map:parameter name="descriptor"
value="context:/docs/test_form.xml"/> but this led to the same error.

It worked if I used context://... or if used the absolute path but this
prevents me from creating a cocoon-application that works independantly from
the root sitemap and independantly from the directory I put it in (the only
thing I need is a mount in the root-sitemap)

Has anybody a solution for my problem?

Reinhard




...
<map:actions>
	<map:action name="add-test"
src="org.apache.cocoon.acting.DatabaseAddAction"/>
	<map:action name="del-test"
src="org.apache.cocoon.acting.DatabaseDeleteAction"/>
	<map:action name="upd-test"
src="org.apache.cocoon.acting.DatabaseUpdateAction"/>
</map:actions>
...
<map:action-set name="test">
	<map:act type="add-test" action="Add"/>
	<map:act type="del-test" action="Delete"/>
	<map:act type="upd-test" action="Update"/>
</map:action-set>
...
<map:match pattern="test.html">
	<map:act set="test">
		<map:parameter name="descriptor" value="docs/test_form.xml"/>
		<map:generate src="docs/test_file.xml"/>
		<map:transform type="sql">
			<map:parameter name="use-connection" value="xxx"/>
		</map:transform>
		<map:transform src="docs/test_HTML.xsl"/>
		<map:serialize type="html"/>
	</map:act>
</map:match>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message