cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <vgritse...@hns.com>
Subject RE: Today's CVS broken?
Date Mon, 13 Aug 2001 19:40:05 GMT
> -----Original Message-----
> From: Christian Haul [mailto:haul@dvs1.informatik.tu-darmstadt.de]
> Sent: Monday, August 13, 2001 11:49 AM
> To: cocoon-dev@xml.apache.org
> Subject: Today's CVS broken?
> 
> 
> Hi Team,
> 
> is it just me or is today's CVS broken?
> 
> (didn't work --> rm -rf work --> build.sh clean --> update to jdk 1.4

JDK1.4 have crimson bundled into rt.jar.


> (was 1.3) --> update to catalina b7 (was b5) --> still doesn't work)

Working config: 
Win2000 + JDK1.3.1 + (Resin 2.0.1 | Tomcat b6 | Tomcat 3.2.3)


> 
> I haven't deployed a snapshot for some days so I can't really tell
> when this happened first.
> 
> BTW: tools.jar is not found with jdk-1.3, jdk-1.3.1, jdk-1.4 it is
> searched in $JAVA_HOME/jre/lib but resides in $JAVA_HOME/lib, this is
> linux with Sun's JDKs

build tries to find tools.jar under ${java.home}, which is set by JRE to __JRE__ installation
directory. Obviously, tools.jar is missing there - it is in __JDK__ installation directory
($JAVA_HOME/lib)
Can you patch build.xml?

PS: It does work for me without tools.jar.

Vadim

> 
> This is how I build it:
> bash build.sh -Dinclude.webapp.libs=yes -Dinstall.war=/projects/haul/jakarta-tomcat-4.0-b7/webapps/
install
> 
> I have attached catalina's logs/localhost_log....txt
> 
> C2 doesn't write any log.
> 
> TIA,
> 
> 	Chris.
> 
> -- 
> C h r i s t i a n       H a u l
> haul@informatik.tu-darmstadt.de
>     fingerprint: 99B0 1D9D 7919 644A 4837  7D73 FEF9 6856 335A 9E08
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message