cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Roebuck <>
Subject Re: AW: [C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)
Date Tue, 14 Aug 2001 12:21:24 GMT

On Tuesday, August 14, 2001, at 12:52  pm, Carsten Ziegeler wrote:

>> Stuart Roebuck wrote:
>> I wonder whether it would be worth considering renaming and/or clarifying
>> the documentation of the modifiedSince() method defined in the Modifiable
>> interface?  The uses of this method in Cocoon appear to fit with the
>> description of the method as implemented in AbstractServerPage, however
>> this definition is probably the exact opposite of what you would expect
>> for a method of this name, and I'm not sure that it is in keeping
>> with the
>> description in
>> I would expect modifiedSince(date) to mean "has this object been modified
>> since the given date, if it has return true".
>> But the implementation is "has this object been modified since the given
>> date, if *not* return true".
>> Unfortunately, I can't think of a better name than:
>> needsRefreshingGivenLastAffectingChangeDateOf(Date dateOfLastUpdate)  :-
>> )
> Let me guess, you are a long time OpenStep (Cocoa, WebObjects) user? 
> Right?
> If so, welcome. If not, you have managed half the way of learning it.
> Carsten

I'm afraid you've completely lost me here.  I've never used OpenStep or 
WebObjects, though I have played with Cocoa a little.  Is this a joke 
about long method names?


Stuart Roebuck                        
Lead Developer                               Java, XML, MacOS X, XP, etc.
ADOLOS                                           <>

To unsubscribe, e-mail:
For additional commands, email:

View raw message