cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Roebuck <>
Subject [C2] Ambiguous API - AbstractServerPage.modifiedSince(long date)
Date Tue, 14 Aug 2001 11:39:45 GMT
I wonder whether it would be worth considering renaming and/or clarifying 
the documentation of the modifiedSince() method defined in the Modifiable 
interface?  The uses of this method in Cocoon appear to fit with the 
description of the method as implemented in AbstractServerPage, however 
this definition is probably the exact opposite of what you would expect 
for a method of this name, and I'm not sure that it is in keeping with the 
description in

I would expect modifiedSince(date) to mean "has this object been modified 
since the given date, if it has return true".

But the implementation is "has this object been modified since the given 
date, if *not* return true".

Unfortunately, I can't think of a better name than: 
needsRefreshingGivenLastAffectingChangeDateOf(Date dateOfLastUpdate)  :-)


Stuart Roebuck                        
Lead Developer                               Java, XML, MacOS X, XP, etc.
ADOLOS                                           <>

To unsubscribe, e-mail:
For additional commands, email:

View raw message