cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craeg K. Strong" <cstr...@arielpartners.com>
Subject Re: [C2.1] LoadTesting and missing returned pages
Date Wed, 22 Aug 2001 17:51:31 GMT


Stuart Roebuck wrote:

> I've noticed recently that requests for pages from Cocoon sometimes 
> appear not to be received and responded to, or return blank pages.  
> For a while I'
> ve just assumed it was some bug in Mozilla, but today I've been 
> testing further and this appears to be a Cocoon issue.
>
> I mention it with regard to LoadTesting, because, if I'm not unique in 
> my experience, then LoadTesting results maybe unrepresentative, if the 
> returned pages aren't complete!
>
> I haven't has a chance to investigate this much, but it looks as 
> though it might be serializing before the content is complete, or else 
> obtaining some blank value from cache rather than generating a new 
> version.  All the problem pages include some degree of aggregation.
>
> Stuart. 

I have noticed similar problems.   For me, hitting the "refresh" button 
once (and sometimes twice) does the
trick.    I am using Cocoon2 beta2 with Tomcat 4.0 beta 7 on Red Hat 
Linux 7.1  with plenty RAM/disk/etc.
I did notice something very interesting yesterday.   I normally start up 
postgresql and use it for my database
(just for the cocoon "personnel" example so far... :-)    But yesterday 
I did not start up postgresql and did not
observe the problem.  All my pages came up right away, fully populated!

Questions:  are you using a database?  Does this behavior occur 
regularly? Intermittently?    Which version of
Tomcat are you using?

--Craeg


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message