cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timm, Sean" <st...@gohealthcast.com>
Subject RE: [VOTE] Require developers to install Ant themselves.
Date Fri, 20 Jul 2001 05:12:33 GMT
Donald Ball [mailto:balld@webslingerZ.com] wrote:
> > > The problem I see is that new versions of Ant can (and 
> have) introduced
> > > various incompatibilities with prior versions.  This 
> means that all projects
> > > have to ensure that they are all using the same version 
> of Ant and that they
> > > all upgrade their build projects and make a new release 
> at the same time
> > > when a new build of Ant is available.  (Or require 
> developers to screw with
> > > switching back and forth between different Ant versions 
> manually every time
> > > they want to build a different project).
> 
> i think that lesson has been learned by the ant developers. ant
> development seems to have slowed quite a bit anyway as it's 
> blossomed into
> a quite capable tool.

The change of pace is true for the current version, but my understanding was
that Ant 2.x would not be backward-compatible with the current 1.x series.
It's been a while since I checked on the progress of Ant 2, though...

- Sean T.

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message