cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From giacomo <giac...@apache.org>
Subject Re: Cannot compile C2
Date Sat, 05 May 2001 14:48:22 GMT

Well, I've checked out the version prior to Carstens commit of the Cache
component which "are now more verbose" from 2001/05/03 11:33.

This version compiles and runs without complains. But as soon as I get
the changed sources from the commit mentioned above I cannot compile the
sources because javac doesn't find the isDebugEnabled method on the
Logger (but javap -classpath lib/logkit.jar org.apache.log.Logger shows
that this method exists)

Does somebody have an explanation?

Giacomo

On Sat, 5 May 2001, giacomo wrote:

>
> Hya guys
>
> I'm in deep trouble :(
>
> Since two days I try to compile my C2 repository without any luck. You
> remember the post I've made yesterday about the issues I had with the
> CocoonServlet, the Main and the Caching*Pipelines. I've tried it with a
> very fresh checkout and that has not solved the problem. The only way I
> get C2 to compile is if I copy the sources from the logkit into the C2
> repository and get rid of the lib/logkit.jar. But then Tomcat-4 barfs
> me a
>
> java.lang.IncompatibleClassChangeError
>         at
> org.apache.cocoon.servlet.CocoonServlet.initLogger(CocoonServlet.java:266)
>
> Anyone having an idea how I can solve these problems? I'm at the end of
> my knowledge. I've checked every issue I know of (ext dir, classpath,
> etc.) but :( .
>
> Giacomo
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
> For additional commands, email: cocoon-dev-help@xml.apache.org
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message