cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <ba...@webslingerZ.com>
Subject [c2] still having caching problems
Date Tue, 08 May 2001 19:30:58 GMT
here's my sitemap:

   <map:match pattern="*">
    <map:aggregate element="root">
     <map:part src="plain/meta"/>
     <map:part src="plain/{1}"/>
    </map:aggregate>
    <map:transform type="xinclude"/>
    <map:act type="resource-exists">
     <parameter name="url" value="context://style/{1}.xsl"/>
     <map:transform src="style/{../1}.xsl"/>
    </map:act>
    <map:select>
     <map:when test="wap">
      <map:transform src="style/wziml-wml.xsl"/>
      <mal:serialize type="wap"/>
     </map:when>
     <map:otherwise>
      <map:transform src="style/wziml-html.xsl"/>
      <map:serialize type="html"/>
     </map:otherwise>
    </map:select>
   </map:match>

   <map:match pattern="plain/*">
    <map:generate src="content/{1}.xml" type="serverpages"/>
    <map:serialize/>
   </map:match>

if i edit wziml-html.xsl, the first change is noticed and applied, but any
changes after that are not. the string 'wziml-html.xsl' does not appear in
cocoon.log anywhere, so there's nothing useful there to report.

personally, i consider this to be a show-stopper bug. no designer is going
to want to work on a system that requires the sysadmin to continually
restart tomcat to see changes.

- donald


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message