cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From giacomo <giac...@apache.org>
Subject Re: I can't declare a namespace in XSP
Date Wed, 25 Apr 2001 08:44:14 GMT


On Wed, 25 Apr 2001, Sylvain Wallez wrote:

>
>
> Berin Loritsch a écrit :
> >
> > I am trying to declare the xforms namespace in a page I am using,
> > however, I am suffering from issues dealing with the namespace
> > stripping algorithm in XSP.
> >
> > I want to use <xform:button> et. al., but every time I try to
> > declare the namespace it gets stripped out.
> >
> Can you please post a sample ? I checked on the latest CVS by altering
> simple.xsp and it's OK.
>
> BTW, I noticed that requesting foo.xsp?cocoon-view=content strips all
> namespace declarations, resulting in an incorrect document, but the
> start/endPrefixMapping are in the generated java source code.

I think you discovered a bug in the XSP engine. I've put a
LogTransformer after the xsp generator into the sitemap. Yes, it report
the start-/endPrefixMappings correctly but as I think having discovered
with the ContentAggregator that is not enough. It should add them as
xmlns attributes to the following element.

Can anybody take a look at it, must be in the xsp.xsl file.

Giacomo


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message