cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carsten Ziegeler" <cziege...@sundn.de>
Subject AW: I have a new error in my execution of Cocon
Date Wed, 11 Apr 2001 15:42:54 GMT
> Von: Giacomo Pati [mailto:giacomo@apache.org]
> 
> Quoting Berin Loritsch <bloritsch@apache.org>:
> 
> > Giacomo Pati wrote:
> > > 
> > > Quoting Berin Loritsch <bloritsch@apache.org>:
> > > 
> > > > If I specify <event-handler
> > > > class="org.apache.avalon.components.pipeline.CachingEventPipeline"/>
> > > 
> > > My specification is <event-pipeline
> > > class="org.apache.cocoon.components.pipeline.CachingEventPipeline"/>
> > > 
> > > and it works for me.
> > 
> > Hmmm.  I checked and rechecked, I did originally write the class name
> > correctly (unfortunately, I didn't in the email).
> > 
> > My first request returns an empty document, and my second request gets
> > the exception below.
> > 
> > I have all the roles specified, and I am not getting any missing
> > component exceptions either.
> > 
> > > 
> > > Giacomo
> > > 
> > > > then I get the error following.  If I use the NonCaching version,
> > then
> > > > all is well.  Is there
> > > > something else I am missing?
> > > >
> > > > DEBUG   42792   [cocoon  ] (Thread-9): Error processing pipeline
> > > > org.apache.cocoon.ProcessingException: Failed to execute
> > > > pipeline.:org.apache.cocoon.ProcessingException: Failed to execute
> > > > pipeline.:org.xml.sax.SAXException: IOException:
> > java.io.EOFException
> > > >
> > > >       at
> > > >
> > >
> > 
> org.apache.cocoon.components.pipeline.NonCachingStreamPipeline.pro
> cess(NonCachin
> > > gStreamPipeline.java:145)
> > > >
> 
> After looking at the stacktrace I see that's the same error I get 
> when I try to 
> request the jakarta sample from the welcome page. The welcome page and (I 
> think) the other samples are working well. I haven't investigated 
> further on but 
> was astonished to see the NonCachingEventPipeline playing around 
> but I have 
> specified the CachingEventPipeline in the xconf file :?
> 
Hmm, this is really strange.
Please check my patch currently submitted if now everything is working.

Carsten


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message