cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Santiago Gala <sg...@hisitech.com>
Subject Re: [C2] doctype error for wap serializer (missing the '>' character)
Date Tue, 13 Mar 2001 12:02:53 GMT
Park, Paul wrote:

> I've downloaded the latest code from CVS and now I'm getting a strange
> behavior.
> 
> When using a serializer with the dtd configuration such as wap serializer
> 
> e.g.
> 
>    <map:serializer name="wap"    mime-type="text/vnd.wap.wml"
> src="org.apache.cocoon.serialization.XMLSerializer">
>     <doctype-public>-//WAPFORUM//DTD WML 1.1//EN</doctype-public>
>     <doctype-system>http://www.wapforum.org/DTD/wml_1.1.xml</doctype-system>
>    </map:serializer>
> 
> it is being serialized incorrectly with a partial dtd declaration
> 
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" 
> "http://www.wapforum.org/DTD/wml_1.1.xml"<wml>...</wml>
> 
> For some reason, '>' character is missing for the doctype declaration in the
> serialized stream? I've browsed through the xml serializer code but it is
> basically calling the classes in xalan.
> 
> Anyone else experiencing this behavior??
> 

Standard "me, too" post :)

It happened shortly one week ago, but then I updated CVS again, rebuilt clean and it worked.
Now, I have done the same (including deleting the workdir) but it does not work.

> Any pointer/hint would be appreciated.

No idea. I tried to trace where the DOCTYPE is serialized, but got lost very quickly.


---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message