cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Burton <r...@itzinteractive.com>
Subject Re: [C2] SVG support dead?
Date Fri, 23 Feb 2001 14:02:10 GMT
On Fri, 23 Feb 2001, Paul Russell wrote:

> Hi all (and Ross in particular if he's up!),

Of course I'm up - I live in London too, guv.  :-)

> There seems to be a problem in the latest C2 CVS with the SVGSerializer.
> It doesn't seem to be receiving the parameters from the sitemap
> configuration, and therefore is not able to find its transcoder. I'm
> looking into it now, but could do with confirmation that others are
> having the same problem? Ross: any ideas?

Well... I've just done a cvs update to ensure I've got the latest updates,
and there is nothing which needs to be committed.  However, now C2 won't
run!  Catalina barfs with this error:

2001-02-23 13:49:40 StandardHost[localhost]: Deploying web application at
context path /cocoon from URL jar:file:/home/users/ross/work/Programming/jakarta-tomcat-4.0-b1/webapps/cocoon.war!/

2001-02-23 13:49:42 StandardHost[localhost]: ContainerBase.addChild:
start: LifecycleException:  start: :  java.lang.IllegalArgumentException: addRepositoryInternal:
java.util.zip.ZipException: error in opening zip file

I've tried several times now and still no joy!  Argh! And I have to be 70
miles away in 2 hours! Argh!  All of the jar files open fine using jar.

I'll state this:
1) I have no more changes to check into the tree
2) Before I checked it in I tested it, and SVG generation and parameter
passing worked fine (the SVG "Hello World" with a bright green background
- nice...)

You're problem could be due to the new Avalon which I think was checked in
a day or so ago.  Maybe Configuration has changed slightly - Berin?  As to
my problem I have no idea!

But I really must go - I am home to read my mails on what was supposed to
be a flying visit, and now I must dash.

Sorry I can't help any more - if it's still broken Sunday night I'll try
and look at it then.
Best of luck! :-)
Ross


Mime
View raw message