cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Scott_B...@lotus.com
Subject Re: Error when using xalan-j 2_0_0 with apply tag
Date Tue, 13 Feb 2001 02:52:39 GMT

The stacktrace is useless, or at least it doesn't tell anything to me.

Does anyone in Cocoon land have a clue as to what may be going on?

-scott




                                                                                         
                         
                    "Krystal Tse"                                                        
                         
                    <ktse@trigonc        To:     <xalan-dev@xml.apache.org>     
                                  
                    anada.com>           cc:     (bcc: Scott Boag/CAM/Lotus)          
                            
                                         Subject:     Error when using xalan-j 2_0_0 with
apply tag                
                    02/12/2001                                                           
                         
                    08:05 PM                                                             
                         
                    Please                                                               
                         
                    respond to                                                           
                         
                    xalan-dev                                                            
                         
                                                                                         
                         
                                                                                         
                         




Hi,

I am using xalan-j 2_0_0 version and I've found that it does not work
with Apply tag in XSL Taglib library.

I receive the following when I run a jsp with using the apply tag in xsl
taglib:



SystemId Unknown; Line 0; Column 0; SystemId Unknown; Line 0; Column 0;
Mon Feb
12 19:49:08 EST 2001:<E> <ServletContext-srvcavail> Servlet failed with
Exceptio
n
javax.servlet.ServletException: runtime failure in custom tag 'apply'
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.fillInStackTrace(Compiled Code)
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at javax.servlet.ServletException.<init>(Compiled Code)
        at jsp_servlet._ProcessServAvail._jspService(Compiled Code)
        at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:105)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:123)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
ContextManager.java:247)
        at
weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
a:361)
        at
weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:261)
        at weblogic.kernel.ExecuteThread.run(Compiled Code)

Mon Feb 12 19:49:08 EST 2001:<E> <ServletContext-srvcavail> root cause
of Servle
tException
javax.servlet.jsp.JspException: org.xml.sax.SAXException: SAX Exception
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.fillInStackTrace(Compiled Code)
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at javax.servlet.jsp.JspException.<init>(JspException.java:73)
        at org.apache.taglibs.xsl.ApplyTag.doEndTag(ApplyTag.java:274)
        at jsp_servlet._ProcessServAvail._jspService(Compiled Code)
        at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:105)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:123)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(ServleSyst
emId Unknown; Line 0; Column 0; SystemId Unknown; Line 0; Column 0; Mon
Feb
12 19:49:08 EST 2001:<E> <ServletContext-srvcavail> Servlet failed with
Exceptio
n
javax.servlet.ServletException: runtime failure in custom tag 'apply'
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.fillInStackTrace(Compiled Code)
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at javax.servlet.ServletException.<init>(Compiled Code)
        at jsp_servlet._ProcessServAvail._jspService(Compiled Code)
        at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:105)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:123)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
ContextManager.java:247)
        at
weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
a:361)
        at
weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:261)
        at weblogic.kernel.ExecuteThread.run(Compiled Code)

Mon Feb 12 19:49:08 EST 2001:<E> <ServletContext-srvcavail> root cause
of Servle
tException
javax.servlet.jsp.JspException: org.xml.sax.SAXException: SAX Exception
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.fillInStackTrace(Compiled Code)
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at javax.servlet.jsp.JspException.<init>(JspException.java:73)
        at org.apache.taglibs.xsl.ApplyTag.doEndTag(ApplyTag.java:274)
        at jsp_servlet._ProcessServAvail._jspService(Compiled Code)
        at weblogic.servlet.jsp.JspBase.service(JspBase.java:27)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:105)
        at
weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:123)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:742)
        at
weblogic.servlet.internal.ServletContextImpl.invokeServlet(ServletCon
textImpl.java:686)
        at
weblogic.servlet.internal.ServletContextManager.invokeServlet(Servlet
ContextManager.java:247)
        at
weblogic.socket.MuxableSocketHTTP.invokeServlet(MuxableSocketHTTP.jav
a:361)
        at
weblogic.socket.MuxableSocketHTTP.execute(MuxableSocketHTTP.java:261)
        at weblogic.kernel.ExecuteThread.run(Compiled Code)



There is a sample coming with the XSL TagLib download from
http://jakarta.apache.org/taglibs/.  It includes the xerces.jar and
xalan.jar.  If I use these two files for my XML parser and XSL
processor, then the apply tag works.  However, it is really necessary
for me to use xalan-j version 2_0_0.


Please kindly advise a solution or is this a bug in xalan-j 2_0_0.

Thanks & Regards,
Krystal





Mime
View raw message