cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Colin Britton" <cbrit...@centervilletech.com>
Subject RE: [C2] Catalina install problems
Date Sun, 25 Feb 2001 12:32:16 GMT
Tried that, you get an error ... javax.servlet.ServletException: Class
org.apache.cocoon.servlet.CocoonServlet is not a Servlet

This is all to do with how Catalina has changed the classloading (while
C2 has also changed its class loading) I think.

I have tried many combinations of places to put the classes and no luck.

rgds
CB


-----Original Message-----
From: Paul Russell [mailto:paul@luminas.co.uk]
Sent: Sunday, February 25, 2001 7:23 AM
To: cocoon-dev@xml.apache.org
Subject: Re: [C2] Catalina install problems


* Colin Britton (cbritton@centervilletech.com) wrote :
> I have just grabbed the latest (2/23/2001 4:50pm) cut of C2 and have
> been trying to get it running with Catalina. My existing version -
about
> a week old, works fine with Catalina 4.0b1 but the latest does not.
Nor
> does it work with the current nightly of Catalina. 
> 
> I have done the usual JAXP and Crimson renaming and use Xerces instead
> but get the following entries in the Cocoon log.
> 
> Any ideas?

This means the servlet api isn't in your compile time classpath. Try
sticking a copy of it in the WEB-INF/lib directory of your webapp?
I'd have thought it would pick that up from the system classpath when
starting tomcat, but maybe not.


Paul.

-- 
Paul Russell                                 Email:   paul@luminas.co.uk
Technical Director                             Tel:  +44 (0)20 8553 6622
Luminas Internet Applications                  Fax:  +44 (0)870 28 47489
This is not an official statement or order.    Web:    www.luminas.co.uk

---------------------------------------------------------------------
To unsubscribe, e-mail: cocoon-dev-unsubscribe@xml.apache.org
For additional commands, email: cocoon-dev-help@xml.apache.org


Mime
View raw message