cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Roebuck <stuart.roeb...@adolos.co.uk>
Subject [C2] Classloader not working with multiple Cocoon versions
Date Mon, 19 Feb 2001 11:21:23 GMT
Trying to get the latest version of Cocoon running I've come across a problem which may or
may not be new news to folk, but was certainly causing me problems getting things running.

I was installing the new version of the cocoon webapp into an Tomcat setup which included
two other contexts with older versions of Cocoon 2 in them.

When I tried to access http://localhost:8080/cocoon/ I was getting an error, and looking at
the cocoon.log I was finding that the Classpath output by cocoon did not contain any of the
library entries in webapp/cocoon/WEB-INF/lib/ - this sent me on a long wild goose chase.

I put in some additional debug traces and discovered that they weren't showing.

Then I tried removing all references in server.xml to my other two cocoon contexts and ran
again.

It worked!

So, it appears that the classloader is using the cocoon classes from one of my older external
webapps defined in server.xml rather than from the cocoon webapp in tomcat/webapp.

Any thoughts?

Stuart.

-------------------------------------------------------------------------
Stuart Roebuck                                  stuart.roebuck@adolos.com
Lead Developer                               Java, XML, MacOS X, XP, etc.
ADOLOS                                             http://www.adolos.com/
Mime
View raw message