cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Berin Loritsch <>
Subject [C2] force-load and DataSources
Date Mon, 08 Jan 2001 13:32:53 GMT
I have a -1 on the aliases saying to use just force-load,
and a +1 on using both.

Can I propose an attribute name that will suit everybody
better.  The thing is we want the configuration to be
friendly to administrators as well as developers.  An
administrator will look at "force-load" with question
marks in their eyes.  How about we use "install-class"
which address both aspects we are trying to capture.

We are programatically forcing the classloader to load
particular classes; however, logically (from the end
user's standpoint) we are installing drivers/handlers,
etc.  It makes better sense.

Ok, for the official vote on the initial parameter's


Due to some of the input already expressed over the weekend,
i like "install-class" (+1) the best.  "force-load" (-1) is
too programmer-centric in its wording (even though I came up
with it).  "driver" (-1) is too narrow in it's scope.

View raw message