cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Russell <p...@luminas.co.uk>
Subject Re: Fresh copy from CVS broken?
Date Thu, 25 Jan 2001 13:01:57 GMT
* Mats Nor?n (mats.noren@spectral.se) wrote :
> I have tools.jar in my cp. And that has worked before...could you be more
> specific to what the problem is?

It's trying to find a modern compiler (JDK1.2.2 and up. I think.) and
failing, and trying to fall back to a classic compiler but barfing when
it tries to log a warning.

> Now in the last substitute the map is empty. Is the sitemap missing a
> listOfMaps.add(map) after I run my Action or is there something else wrong?

That certainly looks likely. Could you do me a favour, and try manually
editing the generated code to add the map, and then delete the
sitemap .class file. Restart cocoon -- hopefully it will recompile the
sitemap class without regenerating the source. Let me know if that fixes
the problem -- if it does, then you've found the bug, and I'll squash it
when I get some time this evening.

Thanks,


Paul.

-- 
Paul Russell                                 Email:   paul@luminas.co.uk
Technical Director                             Tel:  +44 (0)20 8553 6622
Luminas Internet Applications                  Fax:  +44 (0)870 28 47489
This is not an official statement or order.    Web:    www.luminas.co.uk

Mime
View raw message