cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Russell <p...@luminas.co.uk>
Subject Re: Problem with Servlet_2_2.jar
Date Fri, 12 Jan 2001 11:19:14 GMT
* veeras (veeras@indts.com) wrote :
> I have installed JavaWebServer 2.0 on my Solaris with Cocoon Web Publishing
> Framework. Cocoon asks us to include some jar files which includes
> "servlet_2_2.jar". But since JWS already have in build servlet engine, so we
> didn't include this jar file in classpath. Now my program uses functions
> like getAttribute(String) of HttpSession interface which is not included in
> the JWS's "servlet.jar". If I replace the servlet.jar by servlet_2_2.jar
> (JavaWebServer2.0/lib directory) it gives me following error:

The bad news is that Cocoon2 currently *requires* Servlet2.2 compliance,
and from what you're saying, JWS2.0 doesn't offer this. Your options
are:

 * make cocoon work with Servlet 2.0 (I'm not sure on the feasibility of
   this).
 * Use a servlet 2.2 compliant framework (almost certainly the best
   choice if you have that option.

Paul.

-- 
Paul Russell                                 Email:   paul@luminas.co.uk
Technical Director                             Tel:  +44 (0)20 8553 6622
Luminas Internet Applications                  Fax:  +44 (0)870 28 47489
This is not an official statement or order.    Web:    www.luminas.co.uk

Mime
View raw message