cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Russell <>
Subject Re: [C2] Force-Load and DataSources
Date Sat, 06 Jan 2001 16:52:25 GMT
* Berin Loritsch ( wrote :
> I was thinking, we should probably change the name of the
> init parameter "force-load" to "drivers" so that it is
> more clear that this is the perfect place to load the
> JDBC Driver in memory.  Instead of repeating the Driver
> setting and reloading the same class in multiple locations,
> I was thinking that the JDBC drivers should be loaded
> in the init-parameter since the functionality is the same,
> and it is only done once per driver.  That way, connections
> only need the dburl, the user, and the password.

Hmm. However, I tend to stick to the rule that we should use names that
say what they do. 'force-load' does exactly what it says on the tin. The
fact that the drivers happen to register themselves in their static
initializers (or constructors) is a side effect, rather than the aim. I
can see what you're trying to do, but I'm not keen on the implications
for those wishing to force-load non-driver classes. Maybe we could make
them an alias, so both 'force-load' and 'driver' force load a class.


Paul Russell                                 Email:
Technical Director                             Tel:  +44 (0)20 8553 6622
Luminas Internet Applications                  Fax:  +44 (0)870 28 47489
This is not an official statement or order.    Web:

View raw message