cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank Taffelt" <frank.taff...@interface-business.de>
Subject C1 Classloader Problem + Patch
Date Mon, 08 Jan 2001 14:23:01 GMT
Hi,

i'm using cocoon (1.8) with tomcat (3.2.1) .

i tried to separate my application libs from the tomcat libs.

tomcat      in $TOMCAT_HOME/lib (tomcat stuff)
webapp lib  in $TOMCAT_HOME/webapps/cocoon/web-inf/lib (cocoon.jar + my
webapplication libraries)

but cocoon couldn't resolve entries like this :
 resource://org/apache/cocoon/processor/xsp/library/java/context.xsl
 ...
using the system wide classloader.

i made a little patch for "org/apache/cocoon/Utils.java" using another
classloader code
(see my diff file below)

now it is possible to use different cocoon versions

Regards,
frank

P.S. this problem was also mentioned 2 months ago by sergei ivanov





Mime
View raw message