cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <d...@yahoo.com>
Subject Re: [patch] RE: xsp attribute bug? fixed
Date Wed, 27 Dec 2000 21:12:38 GMT
Torsten,
Checked in. Please cross-check.

Thanks,
dims

--- Torsten Curdt <tcurdt@dff.st> wrote:
> I attached the patch to fix this...
> 
> > When I replace the select="text()|xsp:expr" with
> > select="node()" the nodes make their way into the
> > content variable. Although they ARE text nodes -
> > why don't thy get select by text()? They should!!
> > --
> > Torsten
> > 
> > > Cool! But there still seems to be a problem. The "addAttribute"
> > > gets now called at the right place but there seems to be a
> > > problem with it's content!
> > > 
> > >   <test>
> > >     <xsp:attribute name="color">blue</xsp:attribute>
> > >   </test>
> > > 
> > > gives me...
> > > 
> > >   xspAttr.addAttribute("", "color", "color", "CDATA", "");
> > > 
> > > this means: in the xsp:attribute template within the content variable
> > > the for-each selects no text nodes. I can't see why...
> > > 
> > >   <test>
> > >     <xsp:attribute
> > > name="color"><xsp:expr>testString</xsp:expr></xsp:attribute>
> > >   </test>
> > > 
> > > If I have xsp:expr inside the xsp:attribute it works fine.
> > > 
> > > > This should now be fixed.  I ran into that last week, made the fix on
> > > > Thursday or Friday.
> > > > Get new CVS and see if it is still a problem.
> > > 
> > > I just upgraded my xsp.xsl in my CVS version from about 10 days ago.
> > 
> > 

> ATTACHMENT part 2 application/octet-stream name=xsp.patch



=====
Davanum Srinivas, JNI-FAQ Manager
http://www.jGuru.com/faq/JNI

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

Mime
View raw message