cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Berin Loritsch" <blorit...@infoplanning.com>
Subject Re: Redirects and Cocoon 2
Date Mon, 18 Dec 2000 18:30:54 GMT
I encoded all the redirects, but unfortunately, it doesn't work still.
I have a couple of entries in the WebSphere news list, but they have
been less than helpful...

----- Original Message ----- 
From: "Berin Loritsch" <bloritsch@infoplanning.com>
To: <cocoon-dev@xml.apache.org>
Sent: Monday, December 18, 2000 12:03 PM
Subject: Redirects and Cocoon 2


> Does anyone else (beside me) have issues with redirection?
> I am mostly concerned with WebServers/Servlet engine combos.
> 
> Tomcat standalone works great, but WebSphere/IBM HTTP Server
> (based on Apache 1.3.12) does not.
> 
> Basically, the error I get is that when I redirect from
> 
> http://localhost/cocoon/
> 
> to
> 
> http://localhost/cocoon/welcome
> 
> In WebSphere I get:
> 
> http://localhost/welcome
> 
> What makes this even more perplexing is that the same type
> of thing happens at the root context level:
> 
> http://localhost/
> 
> redirected to
> 
> http://localhost/welcome
> 
> yeilds
> 
> http://welcome/
> 
> which is clearly wrong.  All redirects (I know of) are being
> run through HttpServletResponse.encodeRedirectURL(resource).
> 
> Has anyone else solved this issue?
> 
> ---------------------------------------
> If you lust for Ham and Eggs, you have
> committed breakfast in your heart
> already.   -- C. S. Lewis


Mime
View raw message