cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Berin Loritsch" <blorit...@infoplanning.com>
Subject ClassLoader issues...
Date Wed, 06 Dec 2000 16:39:43 GMT
I tried to have Cocoon fully contained within the webapp
(all classpath defined at that level instead of system).
I ran into two problems: WebSphere has XML4J that takes
precedence over Xerces (conflict of org.xml.sax.**),
and Cocoon can't find resources.

First problem I thought no problem, I'll put Xerces in
the main classpath, and there won't be an issue.  This
was a problem because the second issue surfaced.

The classloader that Cocoon had at the point of preparing
for compilation (Sitemap) did not have the reference to
the XSL sheets (sitemap.xsl, et. al.).

At this point, I tried to add just enough packages back
in the main classpath to get the system to work, but
to no avail: we need everything there.

I tried just Cocoon.jar but it couldn't find avalonapi.jar.
I added that in, but it couldn't find the XSLT engine.

My next attempt will be to separate out the XSL pages
into their own Jar file, and see if that works.  It may
be something flaky like the ClassLoader associated with
WebSphere does not recognize a package if there are no
classes in it.  Mayby a Dummy class in each of the
packages with XSL sheets will force it to load.

Any further insight from those who know.

---------------------------------------
If you lust for Ham and Eggs, you have
committed breakfast in your heart
already.   -- C. S. Lewis


Mime
View raw message