cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vadim Gritsenko" <>
Subject [C2][WebLogic] Cocoon2 (patched) works with WebLogic 5.1
Date Mon, 06 Nov 2000 17:10:49 GMT

I successfully launched latest Cocoon2 (from CVS) under WebLogic 5.1
server, but this requires patch to CocoonServlet (attached) which appends
weblogic.class.path to Cocoon's classpath.

I was unable to install Cocoon as described in install.txt,
with all libs in one jar, so here is my installation steps:

1. In order to work with XSP, CocoonServlet must be patched,
   apply attached patch and build cocoon.jar,
2. Preppend WEBLOGIC_CLASSPATH with Cocoon libraries (this way
   I'm overriding old DOM/SAX libraries included with WebLogic),
3. Build and unpack or copy cocoon.war somewhere (I placed it
   under weblogic dir),
4. Add line to
5. Done, run weblogic and go to http://host:port/cocoon/

Hope this will help somebody,

Vadim Gritsenko
(W) 301-428-5500 x 3253
View raw message