cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Torsten Curdt" <tcu...@dff.st>
Subject jrun 3.0 & cocoon2
Date Tue, 28 Nov 2000 09:46:44 GMT
Hi,

I was trying to get cocoon2 (cvs)
to work within jrun 3.0 but didn't
succeed.

After compiling I installed the war
file via JMC. Restarted and then
tried to get /cocoon to show up.
But all I got was a "cocoon2 - internal
server error". Was a sax exception.

Then I tried it like it worked for cocoon1.
(There where problems because of the jaxp.jar
 that came with JRun)
So I replaced the jaxp.jar with cocoons
xerces.jar, copied the tools.jar from the jdk
into the same jrun/lib/ext directory and restarted.

Now I'm still getting a "cocoon2 - internal
server error" but with a NullPointerException.

Then I tried tomcat 3.2b8 as well. Installed
and just popped in the war file.

Same sax exception...
javax.xml.transform.TransformerConfigurationException: Namespace not
supported by SAXParser
at
org.apache.xalan.processor.TransformerFactoryImpl.newTemplates(TransformerFa
ctoryImpl.java:660)

Tomcat comes with jaxp.jar, too.
Shall I replace it with xerces.jar?

Or what am I doing wrong?

Can wait to try out cocoon2 ;-)
Thanks!
--
Torsten


Mime
View raw message