cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Olsen <>
Subject RE: [C2]Action proposal (long)
Date Tue, 14 Nov 2000 00:47:11 GMT

-----Original Message-----
From: Peter Donald []

>>At 12:36  9/11/00 +0100, you wrote:
>>> From: Timm, Sean []
>>> would like to see the "action" attribute changed to "name", 
>>> but I also don't
>>> like the "action" name.  It doesn't fit with all of the other 
>>> component
>>> names we have going.  An action doesn't act.  An actor does.  
>>> Of course,
>>> actor doesn't make sense in this context, so I feel like we 
>>> should use a
>>> different word.  I tried coming up with some words, but I 
>>> wasn't completely
>>> happy with any of them...they are as follows:
>>> delegator-->delegate
>>> conveyor-->convey
>>> relayer-->relay (I don't think relayer is a word).
>>> processor-->process
>>> Any other ideas?
>>I also thing the word action not really incapsulate what it is meant to

>I am curious what you think is lacking.  I guess I come from a GUI
>background and see the ACtion pattern used in a lot of web based projects
>as well (all turbine based ones + some of the jsp taglibs ones at Apache).
>Is there a particular aspect that you don't think it covers ?

It was just that that "parse-information-and-make-available" as was one of
the things "actions" should be made for is and action. An action to me is
something that acts on something and parsing is not action on anything but
ontly convertion from one format to another.

Best regards

Brian Olsen
Management Supporter,
Røjelskær 11, DK-2840 Holte, Denmark
Mobile: +45 4070 2261, Tel.:+45 4546 9900, Fax.: +45 4546 9966
Please take a look at:

The information in this e-mail message is intended only for the
addressee. Disclosure or use by others is prohibited. Due to the
electronic transmission of the message, no legal rights can be
obtained from the content.

View raw message