cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conny Krappatsch <co...@smb-tec.com>
Subject NullpointerException on C2 startup
Date Wed, 27 Sep 2000 12:40:24 GMT
Hi,

I tried to install C2 on Catalina (jakarta-tomcat-4.0-m1) following stefanos
installation guidelines ;-) :
> The "right way" of installing C2 on catalina should be
> 
> ./build.sh -Dinstall.war=../build/tomcat-4.0/webapps
> --Dinclude.webapp.libs=yes install
> 
> and that's it, you don't have to do anything else.
(BTW, documentation suggests something completely different, maybe it's better
to remove this than providing wrong information.)

That seemed to work so far. Catalina works, too.
But if I try to acces C2 ('.../cocoon/welcome') I get a C2 error screen with
the following informations:

type: internal-server-error
message: null
description: java.lang.NullPointerException
sender: org.apache.cocoon.servlet.CocoonServlet
source: Cocoon servlet
stacktrace:
 java.lang.NullPointerException
        at org.apache.cocoon.sitemap.SitemapHandler.process(SitemapHandler.java:127)
        at org.apache.cocoon.sitemap.SitemapManager.invoke(SitemapManager.java:80)
        at org.apache.cocoon.Cocoon.process(Cocoon.java:225)
        at org.apache.cocoon.servlet.CocoonServlet.service(CocoonServlet.java:201)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
        at org.apache.catalina.core.ApplicationFilterWrapper.doFilter(ApplicationFilterWrapper.java:159)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:258)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:936)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:160)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:936)
        at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:1674)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:161)
        at org.apache.catalina.valves.ValveBase.invokeNext(ValveBase.java:242)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:343)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:934)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:159)
        at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:936)
        at org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:787)
        at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:904)
        at java.lang.Thread.run(Thread.java:479)

I could track down the exception and it results from a previuosly occured

java.lang.LinkageError: Class org/xml/sax/Attributes violates loader
constraints

in _sitemap_xmap.class. The code which causes the error is:
confBuilder.startElement ("", "file", "file", attr);

I tried to shuffe some jar packages (catalina comes with xerces +
jaxp + parsers while cocoon's xerces includes all), but without success.

Any further suggestions that could help me getting C2 running.

regards
Conny

-- 
_____________________________________________________________________
Conny Krappatsch                             mailto:conny@smb-tec.com
SMB GmbH                                       http://www.smb-tec.com




Mime
View raw message