cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Francisco Xavier de Figueiredo Júnior <f...@mpdft.gov.br>
Subject RE: C2: NullPointerException
Date Thu, 03 Aug 2000 18:01:09 GMT
 
Hi all,

I think you get this message when C2 is unable ( somehow ) to open
sitemap.xmap file. When C2 doesn't find it, it says that it could not open
the file e shows where it tried to find it. So when I put the file where it
could find it, it showed this NullPointerException error. When you check
console messages you see that it couldn't map relative path from servlet to
system file ( I think IMHO ) and so it can't open the file. So I tried to
put an absolute path and it worked. I don't know if this could be a problem
of the servlet engine, I'm using Resin1.2b and a workaround I found was to
put the name of diretory where my application is as a relative path in the
'file' parameter of sitemap. So I used <sitemap
file='MyCocoon2Site/sitemap.xmap'/> ( in your case it would be
file='cocoon/sitemap.xmap' ) in place of <sitemap file='sitemap.xmap'/> in
the source generated by build webapp Ant task.

I hope it helps.

Francisco Jr.

P.S.: I almost forgot to say that while I'm using build webapp Ant task, I'm
not using cocoon.war file generated. I used the webapp directory contents
and copied everything inside it to my site.




-----Mensagem original-----
De: Johan Müdsam
Para: cocoon-dev@xml.apache.org
Enviada em: 03/08/00 13:25
Assunto: RE: C2: NullPointerException

A small clarification. I don't have jaxp.jar or parser.jar on my
computer
and Cocoon2 still throws the same exception.

Johan Müdsam

-----Original Message-----
From: cocoon-dev-return-6706-johan.mudsam=parabell.com@xml.apache.org
[mailto:cocoon-dev-return-6706-johan.mudsam=parabell.com@xml.apache.org]
On Behalf Of Johan Müdsam
Sent: den 3 augusti 2000 17:09
To: cocoon-dev@xml.apache.org
Subject: RE: C2: NullPointerException


I don't have those files on my computer, sorry.

Johan Müdsam

-----Original Message-----
From: giacomo@wineasy.se [mailto:giacomo@wineasy.se]On Behalf Of Giacomo
Pati
Sent: den 3 augusti 2000 16:30
To: cocoon-dev@xml.apache.org
Subject: Re: C2: NullPointerException


Johan Müdsam wrote:
>
> I'm having problems getting the latest version of Cocoon up and
running. I
> get the following exception thrown at me when I try to access
> http://localhost:8080/cocoon/welcome
>
> Class: java.lang.NullPointerException
> Message: null
> java.lang.NullPointerException
>         at
>
org.apache.cocoon.sitemap.SitemapHandler.process(SitemapHandler.java:145
)
>         at
>
org.apache.cocoon.sitemap.SitemapManager.invoke(SitemapManager.java:84)
>         at org.apache.cocoon.Cocoon.process(Cocoon.java:179)
>         at
>
org.apache.cocoon.servlet.CocoonServlet.service(CocoonServlet.java:142)
>         at
javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
>         at
>
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:
503)
>         at
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:559)
>         at
>
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(H
ttpC
> onnectionHandler.java:160)
>         at
>
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java
:338
> )
>         at java.lang.Thread.run(Unknown Source)
>
> The version of Cocoon2 I'm running is:
> Cocoon 2.0a1 (August 3 2000)
>
> My environment is:
> Windows 2000 Professional
> IIS 5
> Tomcat 3.1
> JDK 1.3
>
> I know there has been a posting of this problem before but I haven't
seen
a
> solution to the problem.
>
> Does anyone have a solution for this?
>
> Thanks in advance,
> Johan Müdsam
>
> <footer>
> parabell ab
> wireless business solutions
> http://wap.parabell.com
> http://www.parabell.com
>
> mobile: +46 (0)703 72 72 96
> </footer>

If you have jaxp.jar and parser.jar in your $TOMCAT_HOME/lib, delete
them.

Giacomo

--
PWR GmbH, Organisation & Entwicklung      Tel:   +41 (0)1 856 2202
Giacomo Pati, CTO/CEO                     Fax:   +41 (0)1 856 2201
Hintereichenstrasse 7                     Mailto:Giacomo.Pati@pwr.ch
CH-8166 Niederweningen                    Web:   http://www.pwr.ch


Mime
View raw message