cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KN Yasa <KNY...@Efavorites.com>
Subject RE: SQLProcessor error
Date Fri, 04 Aug 2000 13:36:59 GMT
Hi Nadine--
 
I guess this code might help you:
 
<?xml version="1.0"?>
<?cocoon-process type="xsp"?>
<?cocoon-process type="sql"?>
<?cocoon-process type="xslt"?>
<?xml-stylesheet href="xsl/favsearch.xsl" type="text/xsl"?>
 
<xsp:page
  language="java"
  xmlns:sql="http://www.apache.org/1999/SQL"
  xmlns:xsp="http://www.apache.org/1999/XSP/Core">
 
  <page title="SQL Search Results">
  <sql:execute-query>
  <sql:driver>weblogic.jdbc.oci.Driver</sql:driver>
  <sql:dburl>jdbc:weblogic:oracle:XXXdatasourcenameXXX</sql:dburl>
     <sql:username>member</sql:username>
     <sql:password>member</sql:password>
  <sql:tag-case>lower</sql:tag-case>
  <sql:null-indicator>yes</sql:null-indicator>
  <sql:doc-element>ROWSET</sql:doc-element>
  <sql:id-attribute-column>none</sql:id-attribute-column>
  <sql:query>select member_first_name from member where member_first_name
like 'na%'</sql:query>
  <sql:count-attribute>nome</sql:count-attribute>
  </sql:execute-query>
  </page>
</xsp:page>
 
If you have any specific questions, I will be very happy to answer you..
 
Thanks
K N Yasa

-----Original Message-----
From: Nadine Carlton [mailto:nadine_carlton@hp.com]
Sent: Thursday, August 03, 2000 7:10 PM
To: cocoon-dev@xml.apache.org
Subject: SQLProcessor error


Hi,
 
  I've just installed Cocoon.  I have the Cocoon.xml status page coming back
and the hello-page.xml works as well.  Unfortunately, I'm having trouble
getting
the database-page.xml working.  I have updated the connection information
and the query for my NT 8.1.5 Oracle database to access the demo emp table,
but 
the returned page in the browser displays "select * from emp".
The xml looks like:
<?xml version="1.0"?>

<?cocoon-process type="sql"?>

<page><connectiondefs>

<connection name="evue_customer_connection">

<driver>oracle.jdbc.driver.OracleDriver</driver>

<dburl>jdbc:oracle:thin:@nc703572:1521:orant815</dburl>

<!--<username>scott</username>

<password>tiger</password>-->

</connection>

</connectiondefs> 

<sqlerror message="The database connection failed."/>

<query connection="evue_customer_connection">

select * from emp

</query>

</page>

I turned on debug in the cocoon.properties file, but there are no 

errors there.  The jdbc and cocoon libraries are in my wrapper.classpath
also. What

else can I do to debug this?

Nadine Carlton 


Mime
View raw message