cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Sahuc <ssa...@imediation.com>
Subject [RE] strange xsp namespace behavior.
Date Thu, 31 Aug 2000 14:53:05 GMT
Sorry, the change underlined below don't correct the namespace problem, 
it helps a little but don't erase it completely. Indeed in the HTML, 
there is still some 

Soryy again for the wrong info, I'm despairing now :-)

Sebastien

>>>>>>>>>>>>>>>>>> Original Message
<<<<<<<<<<<<<<<<<<

On 8/31/00, 4:30:44 PM, Sebastien Sahuc wrote 
regarding strange xsp namespace behavior.:


> I confirm a previous post stating a strange behavior in XSP namespace.

> Below are my observation I've done so far :

> The file 'org/apache/cocoon/components/language/markup/xsp/java/xsp.xsl'

> in the current CVS has a different namespace value that defined in
> cocoon.xconf. Indeed the value is "http://xml.apache.org/xsp" whereas it

> should have been 'http://xml.apache.org/cocoon/xsp"

> So when I change the former value to the latter, the ProcessingException

> (which is wraping a NullPointerException ) disappears and the simple.xsp

> SEEMS to be working.

> I say seems, because in the generated HTML source, there is still trace
> of incoherence, as Giacomo stated in a post. Indeed the following tags
> have not being dynamically processed and appears in the HTML as is :
> 
> 


> SO, I changed the namespace values in several files, and I made the
> cocoon working fine !!!

> Here are the change I've done.

> In the files simple.xsp, request.xsl, and response.xsl replace
> 'xmlns:xsp-request="http://xml.apache.org/cocoon/xsp/request"'
> with
> 'xmlns:xsp-request="http://xml.apache.org/xsp/request"'
> and
> xmlns:xsp-response="http://xml.apache.org/cocoon/xsp/response"
> with
> xmlns:xsp-response="http://xml.apache.org/xsp/response"


> And in cocoon.xconf, replace
> 
> value="http://xml.apache.org/cocoon/xsp/request"/>
> with
> http://xml.apache.org/xsp/request"/>
> and
> 
> value="http://xml.apache.org/cocoon/xsp/response"/>
> with
> http://xml.apache.org/xsp/response"/>


> Strange... definitely strange.

> Has anyone an idea of what is going on ?

> All the best,

> Sebastien



Mime
View raw message