cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giacomo Pati <pati_giac...@yahoo.com>
Subject Re: C2 weird XSP bug?
Date Wed, 30 Aug 2000 07:45:09 GMT

--- chip-cocoon-dev@galaxia.dataway.ch wrote:
> Hi,
> 
> There's something weird about the XSP processor in C2, specifically
> the
> xsp:page tag. I have
> 
> <?xml version="1.0"?>
> <xsp:page language="java"
> xmlns:xsp="http://xml.apache.org/cocoon/xsp">
> 	<page>lala</page>
> </xsp:page>
> 
> This gives me an exception org.apache.cocoon.ProcessingException.
> 
> If I add the namespace
> 
> xmlns:xsp-request="http://xml.apache.org/cocoon/xsp/request"
> 
> the thing works. It also works when I use
> 
> xmlns:xsp-response="http://xml.apache.org/cocoon/xsp/response"
> 
> It even works with
> 
> xmlns:xsp-response="http://www.microsoft.com"
> 
> although then the namespace doesn't have the semantics it's supposed
> to.
> 
> It's only when neither xsp-request nor xsp-response are set that the
> error appears.
> 
> What's going on?

I feel that something has changed namespace stuff some days/weeks ago
at many places. I still didn't had the time to check it out. I hope to
have  time the next two days to look at it together with Stefano.

BTW: You don't have the xsp-request/xsp-response taglib functioning,
don't you?

Giacomo

=====
--
PWR GmbH, Organisation & Entwicklung      Tel:   +41 (0)1 856 2202
Giacomo Pati, CTO/CEO                     Fax:   +41 (0)1 856 2201
Hintereichenstrasse 7                     Mailto:Giacomo.Pati@pwr.ch
CH-8166 Niederweningen                    Web:   http://www.pwr.ch

__________________________________________________
Do You Yahoo!?
Yahoo! Mail - Free email you can access from anywhere!
http://mail.yahoo.com/

Mime
View raw message