cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett McCormick <>
Subject cocoon 1.7.5-dev issues under freebsd
Date Tue, 08 Aug 2000 21:55:09 GMT

I'm using the latest version of cocoon out of cvs (the error page says
Cocoon 1.7.5-dev) and I'm having some troubles on FreeBSD 4.0.  I've
also had similar problems using cocoon 1.7.3.  The last version that I
was able to use was 1.7.0 but I'm betting it has some bugs that more
recent versions have fixed.

However, I seem to be running into some sort of VM bug (possible -- I
don't know enough about java to tell).  I attempted to debug the
problem, but I had trouble getting the java debugger up and running.
I was hoping someone on this list might have some tips.

Architecture: intel x86 (dual p2)
Operating System: FreeBSD 4.0
JDK version: jdk 1.1.8
xalan version: 1_1_D01
xerces version: 1_1_2
apache jserv:
jsdk version: 2.0

xalan and xerces are coming right out of the jar files in
xml-cocoon/lib from the CVS repository.

xalan works great on the command line, but cocoon never seems to work
and I get bizarre error messages, shown below.

If anyone has any advice or needs more information, I would be happy
to provide it.  I could also send you the contents of my *.properties
files, which are the same as the ones I used in 1.7.0..


error message:

Publishing Engine could not be initialized.

            at org.apache.cocoon.framework.Manager.create(
            at org.apache.cocoon.framework.Router.init(
            at org.apache.cocoon.framework.Manager.create(
            at org.apache.cocoon.Engine.(
            at org.apache.cocoon.Engine.getInstance(
            at org.apache.cocoon.Cocoon.init(
            at org.apache.jserv.JServServletManager.load_init(
            at org.apache.jserv.JServServletManager.loadServlet(
            at org.apache.jserv.JServConnection.processRequest(

View raw message