cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <ba...@webslingerZ.com>
Subject Re: [C2] Package names
Date Sat, 08 Jul 2000 01:02:15 GMT
On Fri, 7 Jul 2000, Stefano Mazzocchi wrote:

> Ok, at the end I propose the following naming:
> 
>    verb    |    action      |    actor
> -----------+----------------+--------------
>  generate  | generation     | generator
>  transform | transformation | transformer
>  serialize | serialization  | serializer
>  select    | selection      | selector
>  match     | matching       | matcher
> 
> then the interface for every component category will be placed in
> 
>  org.apache.cocoon.[action].[actor]
> 
> Please, PLEASE, let's agree on this. 

+1, now that the grammar police have had their way.

- donald


Mime
View raw message