cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edwards, Jayme" <JCEdwa...@software.rockwell.com>
Subject RE: SAXParse error (cant find the file) when parsing stylesheets withcocoon
Date Wed, 12 Jul 2000 20:19:29 GMT
As a side note this happens in 1.1 as well. The only "visible" (without inspecting the source)
change to Xerces in this timeframe is the schema validation feature, which may not be turned
off by cocoon by default.

Jayme

-----Original Message-----
From: Berin Loritsch [mailto:bloritsch@infoplanning.com]
Sent: Wednesday, July 12, 2000 1:31 PM
To: cocoon-dev@xml.apache.org
Subject: Re: SAXParse error (cant find the file) when parsing
stylesheets withcocoon


Berin Loritsch wrote:
> 
> "Edwards, Jayme" wrote:
> >
> > I updated a project that uses cocoon to use Xerces 1.1.2 and I get the following
error
> > whenever I try to browse XML documents that have the <?xml-stylesheet and <?cocoon-process
> > tags (these used to perform the transformation without a problem). It almost looks
like a pathing
> > problem in the source for Xerces???
> >
> > org.xml.sax.SAXParseException: File "D:/projects/<directory-name-omitted>/index.xml"
not found.
> >
> > Note <directory-name-omitted> was added by me and not returned by cocoon.
> >
> > Jayme
> 
> I get the same error!
> I thought it was my configuration.  Try down-grading to 1.1.1 and see if
> that changes anything.
> 
> I get the same error regardless of Cocoon 1 or Cocoon 2.
> 
> But all the configuration files load and parse OK.  Anyone know what's going on?

In Cocoon2, it appends
<!-- PATH_INFO="null" -->
to the file.  Is this related?  if the PATH_INFO is always null when it gets
to Xerces, of course we will have problems.

Mime
View raw message