cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Washeim <esa...@canuck.com>
Subject Re: [C2] Package names
Date Tue, 04 Jul 2000 13:42:23 GMT
on 4/7/00 3:32 pm, Mark Washeim at esalon@canuck.com wrote:

> on 4/7/00 1:49 pm, Stefano Mazzocchi at stefano@apache.org wrote:
> 
>> Giacomo Pati wrote:
>>> 
>>> --- Niclas Hedhman <niclas@localbar.com> wrote:
>>>> Niclas Hedhman wrote:
>>>> 
>>>>> In the sitemap proposal there are
>>>>> 
>>>>> org.apache.cocoon.matcher
>>>>> org.apache.cocoon.transformer
>>>>> org.apache.cocoon.chooser
>>>>> org.apache.cocoon.serializer
>>>>> 
>>>>> but
>>>>> org.apache.cocoon.generators
>>>>> 
>>>>> in pluralis...
>>>>> Inconsistent. Personally I would prefer the pluralis (with s) on all
of
>>>>> them, but I think all agree that mixing should not be used.
>>>> 
>>>> Personally I use another 'pattern'.
>>>> 
>>>> org.apache.cocoon.transformation
>>>> org.apache.cocoon.generation
>>>> :
>>>> :
>>>> 
>>>> Since it will normally not only contain the "transformers", but also
>>>> support classes, exceptions and so on.
>>>> 
>>>> Problem a bit with match and choose...
>>> 
>>> org.apache.cocoon.matching
>>> org.apache.cocoon.choosing
>>> 
>>> I do like this argumentation for naming, too.
>> 
>> I do too.
>> 
>> I don't like
>> 
>> org.apache.cocoon.transformer.Transformer
>> 
>> it makes sense to have
>> 
>> org.apache.cocoon.[action].[actor]
> 
> This isn't correct, is it? it's package (containter) class, not abstraction
> of type one and abstraction of type two????
> 
> After all, the actions in question could well use actors from quite
> different packages, no?
> 
> 
>> type of naming convention.
>> 
>> +1
> 
> Well, I disagree, on principal. Objects are not actions, in any case. They
> encapsulate identity. Hence, are best named as nouns. I'm being a bit anal
> about packages and objects, I know, and it makes little difference in
> reality, but 
> 
> Of course, transformation.ExplicitTransformation is fine (better than
> transformer), but matching and choosing. Yech.
> 
> org.apache.cocoon.match.MatchThis
> org.apache.cocoon.choose.ChooseThis
> 

Of course, in deference to my own polemic, choice, not choose :)
But, now I really need to look at the site-map for cocoon 2. Damn. :)

> and shouldn't it be:
> org.apache.cocoon.map.match.MatchThis
> org.apache.cocoon.map.choose.ChooseThis
> (or some such) . . .
> 
> just my two bits . . .
> 
> 
> 

-- 
Mark (Poetaster) Washeim

'On the linen wrappings of certain mummified remains
found near the Etrurian coast are invaluable writings
that await translation.

Quem colorem habet sapientia?'

Evan S. Connell

 



Mime
View raw message