cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Lancelle <...@knosys.com>
Subject Re: Building Cocoon 2 - warnings, exceptions and errors
Date Mon, 24 Jul 2000 04:52:38 GMT
Downloaded the latest cvs version, and got the docs to create. But still
get IllegalAccessException when trying to access an xml file which was
accessible under Cocoon 1.

I have changed all the permissions on the *.jar files to chmod 755, and
still no luck. I have java installed under root, and all other packages
(tomcat,cocoon,ant, etc.) under a user. I start the server from root,
and tomcat from the user shell. Of course, I have tried starting tomcat
from root also, with the same results.

Haven't touched the java.policy file...don't even know what it is. I'll
look at it.

Also, I have created links to all needed *.jar files under the
tomcat_home/lib directory. Links used to work fine with cocoon 1. Could
this be a problem?

Jon Lancelle



Berin Loritsch wrote:

> "N. Sean Timm" wrote:
> > >* When trying to access *.xml pages, get this:
> > ...org/apache/cocoon/Cocoon - java.lang.IllegalAccessException:
> > >org/apache/cocoon/Cocoon...
> >
> > Not sure on this one...
>
> Check the permissions of the jar file and the directories it's in.
> UNIX will not allow you access to many files if it was created by
> root and used by another user.
>
> Try 'ls -l' to get the permissions on the jar and surrounding
> directory.  If you get a result that looks like this:
>
> -rwxr-x--- root root  9287532  cocoon.jar
>
> that means that the user 'root' has read/write/execute privilege,
> the group 'root' has read/execute privilege, and nobody else has
> any privilege at all.
>
> Something more useful would be to change it's mode like this:
>
> chmod 755 cocoon.jar
>
> Which still only allows the user and root to delete/modify the
> file, but everyone else can read and execute.
>
> Do that for the surrounding directory too, because sometimes
> you can't read the directory which will also give you the
> IllegalAccessException even if the file itself is OK.
>
> And lastly, did you do _anything_ to the java.policy file?
Mime
View raw message