cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Lancelle <...@knosys.com>
Subject Re: Was great, now doom and gloom...
Date Sun, 02 Jul 2000 08:01:37 GMT
I've go tto get some sleep.

Problem solved. For some reason, I placed a copy of cocoon.jar and Tomcat servlet.jar under
$JAVA_HOME/jre/lib/ext. After removing from this directory (of course, installed under $TOMCAT_HOME/lib),
all worked fine again.

'The doom and gloom is gone, and now the light shines down!!!' (now all I have to do is write
something...)

Jon Lancelle


Jon Lancelle wrote:

> I just had Cocoon working great with Tomcat 3.1.
>
> Then did something...?? Wish I could remember..oh yeah, tried to build a
> cvs of ant...but didn't use the build.
>
> Now I get the following message whenever I try to access an xml file
> with Cocoon running:
>
>             Publishing Engine could not be initialized.
>
>     java.lang.RuntimeException:
>         Error creating org.apache.cocoon.parser.XercesParser: make sure
> the needed classes can be found in the classpath
> (org/xml/sax/ErrorHandler)
>     at org.apache.cocoon.framework.Manager.create(Manager.java:114)
>     at org.apache.cocoon.Engine.(Engine.java:133)
>     at org.apache.cocoon.Engine.getInstance(Engine.java:202)
>     at org.apache.cocoon.Cocoon.init(Cocoon.java:141)
>     at
> org.apache.tomcat.core.ServletWrapper.initServlet(ServletWrapper.java:315)
>
>     at
> org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:445)
>
>     at
> org.apache.tomcat.core.ContextManager.service(ContextManager.java:559)
>     at
> org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:160)
>
>     at
> org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java:338)
>
>     at java.lang.Thread.run(Thread.java:484)
>
> I have gone through the faqs and over the installation several times,
> with no results. In my context, I have modified web.xml to look for the
> cocoon.properties file (I place it under WEB-INF...as before the great
> gloom). Also, when Tomcat starts up, the *.jar files build the path
> correctly, placing the Xerces jar before the xml jar. In fact, I tried
> removing the xml.jar file. Tomcat startup balks...must need it.
>
> Any ideas? Maybe reinstall?
>
> Thanks,
> Jon Lancelle
Mime
View raw message