cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Giacomo Pati <Giacomo.P...@pwr.ch>
Subject Re: [C2] Package names
Date Sat, 08 Jul 2000 05:24:52 GMT
On Fri, Jul 07, 2000 at 08:54:56PM +0200, Stefano Mazzocchi wrote:
>  
> [...snipped...]
> 
> Ok, at the end I propose the following naming:
> 
>    verb    |    action      |    actor
> -----------+----------------+--------------
>  generate  | generation     | generator
>  transform | transformation | transformer
>  serialize | serialization  | serializer
>  select    | selection      | selector
>  match     | matching       | matcher
> 
> then the interface for every component category will be placed in
> 
>  org.apache.cocoon.[action].[actor]
> 
> Please, PLEASE, let's agree on this. 

+1 I hope it's the last vote on nameing 

Giacomo

-- 
PWR GmbH, Organisation & Entwicklung      Tel:   +41 (0)1 856 2202
Giacomo Pati, CTO/CEO                     Fax:   +41 (0)1 856 2201
Hintereichenstrasse 7                     Mailto:Giacomo.Pati@pwr.ch
CH-8166 Niederweningen                    Web:   http://www.pwr.ch


Mime
View raw message