cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rogerio Lacerda" <rogerfo...@newmail.net>
Subject Re: [Cocoon Devel] Re: XSPSQLLibrary and jdk 1.2 or 1.3
Date Thu, 06 Jul 2000 18:53:12 GMT
Do u deleted the attribute ???

I got here perfectly !!!


----- Original Message -----
From: Jon Lancelle <jkl@knosys.com>
To: <cocoon-dev@xml.apache.org>
Sent: Thursday, July 06, 2000 11:36 PM
Subject: Re: [Cocoon Devel] Re: XSPSQLLibrary and jdk 1.2 or 1.3


> I dug into the code, and noticed it wanted to see a non-null
> count-attribute. After putting one in, I get the count attribute with a
large
> numbers of records in the result set showing in the output (as expected.)
Still
> there is no output of the record data. I will dig a bit further and find
out
> what's up. Perhaps many more sql namespace elements need to be defined
than are
> alluded to in the docs.
>
> Now outputs:
>
> <table numrecs="1300" result="0"></table>
>
> Jon Lancelle
>
>
>
>
>
> Rogerio Lacerda wrote:
>
> > I think u must delete the attribute 'update-rows-attribute' or set like
> > 'update-rows-attribute=no'...try this...
> >
> > ----- Original Message -----
> > From: Jon Lancelle <jkl@knosys.com>
> > To: <cocoon-dev@xml.apache.org>
> > Sent: Thursday, July 06, 2000 10:37 PM
> > Subject: [Cocoon Devel] Re: XSPSQLLibrary and jdk 1.2 or 1.3
> >
> > > Donald,
> > >
> > > Using the following xml file (based on example from installation), I
get a
> > > result file which appears somewhat like...
> > >
> > > ...
> > > <table result="0"></table>
> > > ...
> > >
> > >
> > > I have used the same info below with the SQL processor, and it works
fine.
> > >
> > > I also tried running it through a stylesheet with no luck.
> > >
> > > Thanks for the look.
> > >
> > >
> > >
> > >
> > > *********************************
> > >
> > > <?xml version="1.0"?>
> > >
> > > <?cocoon-process type="xsp"?>
> > >
> > > <xsp:page
> > >   language="java"
> > >   xmlns:sql="http://www.apache.org/1999/SQL"
> > >   xmlns:xsp="http://www.apache.org/1999/XSP/Core"
> > > >
> > >
> > > <page>
> > >
> > >  <sql:execute-query>
> > >   <sql:driver>ovjdbc.OvrimosDriver</sql:driver>
> > >   <sql:dburl>jdbc:ovrimos://63.202.207.116:3000</sql:dburl>
> > >   <sql:username>myuserid</sql:username>
> > >   <sql:password>mypassword</sql:password>
> > >   <sql:query>select * from orchestral</sql:query>
> > >   <sql:doc-element>table</sql:doc-element>
> > >   <sql:row-element>row</sql:row-element>
> > >   <sql:update-rows-attribute>result</sql:update-rows-attribute>
> > >   <sql:tag-case>lower</sql:tag-case>
> > >   <sql:null-indicator>yes</sql:null-indicator>
> > >   <sql:id-attribute>ID</sql:id-attribute>
> > >   <sql:id-attribute-column>folio</sql:id-attribute-column>
> > >  </sql:execute-query>
> > >
> > > </page>
> > >
> > > </xsp:page>
> > >
> > >
> > >
> > >
> > >
> > >
> > > Donald Ball wrote:
> > >
> > > > > I am using jdk 1.3 beta from sun on a linux box. For some reason
I
> > can't
> > > > > get results using the XSP SQL Processor.
> > > > >
> > > > > I do get results using just SQL Processor...all info essentially
the
> > > > > same between the two.
> > > > >
> > > > > I even compiled a recent cvs version of Cocoon, and still get no
> > > > > results. Could it be the jdk 1.3 version?
> > > >
> > > > that's really unlikely - perhaps you could post your xsp page and
we'll
> > > > have a look-see?
> > > >
> > > > - donald
> > > _______________________________________________
> > > Cocoon-devel mailing list
> > > Cocoon-devel@lists.real-time.com
> > > https://mailman.real-time.com/mailman/listinfo/cocoon-devel
> > >
> _______________________________________________
> Cocoon-devel mailing list
> Cocoon-devel@lists.real-time.com
> https://mailman.real-time.com/mailman/listinfo/cocoon-devel


Mime
View raw message