cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ricardo Rocha <rica...@apache.org>
Subject Re: XSP taglib question
Date Wed, 14 Jun 2000 05:43:12 GMT
Donald Ball wrote:
> 
> On Wed, 14 Jun 2000, Giacomo Pati wrote:
> 
> > Donald Ball wrote:
> > >
> > > Here's the header from my taglib stylesheet:
> > >
> > > <xsl:stylesheet
> > >   xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
> > >   xmlns:news="http://www.webslingerZ.com/XML/News"
> > >   xmlns:sql="http://www.apache.org/1999/SQL"
> > >   version="1.0"
> > > >
> >
> > And this is mine, silly question: did you add your taglib in the
> > cocoon.properties (I know I shouldn't ask you :)?
> >
> > <xsl:stylesheet version="1.0"
> >    xmlns:sql="http://www.apache.org/1999/SQL"
> >    xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
> >    xmlns:pwr="http://www.pwr.ch/2000/XSP/PWR"
> >    xmlns:xsp="http://www.apache.org/1999/XSP/Core"
> 
> I did, yes. Certainly you should ask me - it's the most obvious thing to
> be wrong. But I _know_ it's finding the taglib since the document it
> creates does contain the results of the transformation - it just never
> passes the results back to the xsp processor for further processing.
> 
> > <xsp:page
> >   xmlns:sql="http://www.apache.org/1999/SQL"
> >   xmlns:pwr="http://www.pwr.ch/2000/XSP/PWR"
> >   xmlns:xsp="http://www.apache.org/1999/XSP/Core"
> > >
> >
> > > Am I doing something wrong or is this simply not possible in XSP itself?
> >
> > I hope this helps you a bid.
> 
> A bit, yes. I actually just got it working by explicitly invoking my
> taglib using the xml-logicsheet PI. That implies that the relying
> on the namespace prefix matching a global logicsheet doesn't work - but
> you say it works fine for you. I reckon there's some difference in either
> our taglibs or our configurations that's causing us to get two different
> results. what's your taglib like?

The order in which namespace-declared logicsheets are applied is the
same
order in which namespaces are declared in the root <xsp:page>. This
might
have something to do with your problem...

Other than that, logicsheets declared explicitly by means of
<?xml-logicsheet?>
should behave exactly like those declared implicitly by means of
namespaces.

Ricardo

Mime
View raw message