cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sven Kuenzler <sv...@gmx.net>
Subject Cocoon with Tomcat, part (n+1) ...
Date Sat, 06 May 2000 13:05:55 GMT
Hi,

I have a problem using the new 1.7.3 with Cocon (again).

I copied the lib/*.jar from the new distribution to the tomcat lib
directory.
Then I altered my web.xml to point to the new 1.7.3 cocoon.properties. I
edited this file according to my environment (I set the path to the
repository).

When trying to access a xml file, however, I got an error about the
XHTMLFormatter which could not be accessed. Well, I don't need XHTML
anyway, so I commented it out.

Now it worked. Well, that was too easy. And indeed, I forgot a small
little thing. I forgot to replace the cocoon.jar!

Now after replacing cocoon-1.7.3-dev with the release version, I get the
following exception
---
Publishing Engine could not be initialized.

       java.lang.NullPointerException
               at org.apache.cocoon.Cocoon.init(Cocoon.java:135)
               at
org.apache.tomcat.core.ServletWrapper.initServlet(ServletWrapper.java:315)
               at
org.apache.tomcat.core.ServletWrapper.handleRequest(ServletWrapper.java:445)
               at
org.apache.tomcat.core.ContextManager.service(ContextManager.java:559)
               at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:160)
               at
org.apache.tomcat.service.TcpConnectionThread.run(SimpleTcpEndpoint.java:338)
               at java.lang.Thread.run(Thread.java:475)
---

Please note that the new configuration and the lib jars worked with the
old -dev-version (probably a 2-weeks-old cvs snapshot). So, what might
be wrong here?

	Sven....

Mime
View raw message