cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michel Lehon" <>
Subject Store interface for Cocoon 2.
Date Fri, 07 Apr 2000 14:12:38 GMT

I just had a look at the Store interface in Cocoon 2 and I wonder about 2

1°) wouldn't 'containsKey' method best named 'contains' ?
    I think it would be more consistent with the other method names.

2°) is the 'keys()' method needed ?
    I can't see any good reasons why a Store user would need to enumerate
the keys.
    It would also give more freedom of implementation to get rid of it.
    There was an equivalent in Cocoon 1.x (list()) but it was only used
    by the Store itself for the Status page.

Would it help if I try to make an implememtation of MemoryStore for Cocoon2
(based on the one I just made for Cocoon 1.x) ? Is it of any use for the
moment ?

I know I only talk about Store, but hey that's a start. ;)



Michel Lehon
SAS DataWarehousing & Web Enablement.

View raw message