cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ricardo Rocha <rica...@apache.org>
Subject Re: XSP class package name problem
Date Thu, 27 Apr 2000 18:33:58 GMT
Oops!

I mistakenly sent this to the list, sorry

On Thu, 27 Apr 2000, you wrote:
> Hi Roberto,
> 
> I've been unable to replicate this problem. I originally
> thought it may be due to directories "one" and "two"
> (or their "page.xml" entries) being [symbolic] links,
> but the package name generator works correctly
> even in these cases....
> 
> Could you, please, send me more detailed info
> about this problem and your setup?
> 
> Thanks in advance (and, please, forgive my delay
> in replying: I've been sick)
> 
> Regards,
> 
> Ricado
> 
> PD: VocÍ fala portuguÍs o, tal vez, espaŮol?
> 
> On Mon, 10 Apr 2000, you wrote:
> > I got 2 XSP pages under my DocumentRoot :
> > 
> >  /one/page.xml
> >  /two/page.xml
> > 
> > If I GET the pages my XSP repository looks like that :
> > 
> >  ./_my/_document/_root/_one/_page.java
> >  ./_my/_document/_root/_one/_page.class
> > 
> >  ./_my/_document/_root/_two/_page.java
> >  ./_my/_document/_root/_two/_page.class
> > 
> > but the package in the two files are the same :
> >  
> >   package _my._document._root;
> > 
> > instead of :
> > 
> >   package _my._document._root._one;                                
> >   package _my._document._root._two;                                
> > 
> > then I get :
> > 
> >   java.lang.ClassFormatError: Duplicate name
> > 
> > when I GET the second "page.xml".
> > Any Clues?
> > 
> >   Rober
> > 
> > Thanks in advance. 
> > 
> > -- 
> > Roberto Moreda Alvarez
> > Alfa21 Outsourcing S.L.

Mime
View raw message