cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Ball <ba...@webslingerZ.com>
Subject Re: Prob compiling CVS source w/ 1.1.8 JDK
Date Thu, 06 Jan 2000 20:13:37 GMT
On Thu, 6 Jan 2000, Seth Ladd wrote:

> Hello,
> 
> I just pulled down the CVS source of Cocoon and attempted to compile it
> with the IBM 1.1.8 JDK for Linux (2.2.13).  It appears as if there are
> Java 1.2 classes/methods being used.  Here is one of the many errors that
> appear
> 
> /home/sladd/src/xml-cocoon/build/src/org/apache/cocoon/processor/xsp/library/XSP 
> GlobalLibrary.java:110: Undefined variable or class name: Arrays 
>     Arrays.sort(attributeNames); // Since Java2 
>     ^ 
> 
> I would vote that Cocoon remain 1.1.x compatible, until at least many
> other platforms get good, solid 1.2 support. Was this a conscious
> decision, or did the 1.2 stuff slip in by accident?

By accident, or at least not by the group's conscious decision. While I
now have good JDK-1.2 support on my primary platform, there are some major
platforms still in the cold. I vote for 1.1 compatibility still.

- donald


Mime
View raw message