cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ricardo Rocha" <rica...@apache.org>
Subject RE: requires JDK 1.2
Date Sun, 23 Jan 2000 20:03:48 GMT
On Jan-23-2000 Mike Engelhart wrote:

> Unfortunately I have found a Java 2 dependency in XSPClassLoader.java
> (Cocoon 1.6)
> Line 82-83 has this:
> if (bits == null) {
>    ClassLoader cl = getParent(); // Hmmm...
> (Notice the comment in the source)

This class (like all XSP-related classes) was modified to remove
dependencies on Java2. In particular, getParent() (Java2) has
been replaced by this.getClass().getClassLoader() (Jdk 1.1). XSP
was never meant to require Java2, so all early-development
dependencies were removed prior to releasing Cocoon 1.6.

> Can anyone tell me how to get around this so I can recompile and get this
> working so I don't have to go back to the dreaded JSP model of
> programming. I can't wait for Cocoon 1.7 to have this fixed.  I'm not sure
> what that call is in there for so any workarounds would be greatly
> appreciated. You also may want to change the docs to say that Cocoon
> requires Java 2 to work with XSP so others don't get frustrated with this.

Since this class was last modified on Jan-15 and Cocoon 1.6 was released
on Jan-18, I can only assume your Cocoon version is out date. You may
download the most recent Cocoon jar or check it out of the CVS.

Regards,

Ricardo


Mime
View raw message