cocoon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Wolpert <wolp...@radiancegroup.com>
Subject ProducerFromFile problems with Cocoon 1.6 and servlet API 2.0 (an d 2.1)
Date Tue, 18 Jan 2000 22:25:08 GMT
Folks-

  I'm starting to upgrade from Cocoon 1.5 to Cocoon 1.6 with 
JServ 1.1b3 (not 1.1 yet...) I'm also using Servlet API 2.0
release. I extended the ProducerFromFile class, and tried to
recompile, but it fails when it hits the request.getContextPath()
in line 100 of ProducerFromFile.java. The getContextPath() is
only available with HttpServletRequest object in servlet 
API 2.2, not 2.0. Does Cocoon still work with the servlet API 2.0, 
or does it require 2.2 now? If so, What does this mean with Jserv?
Mime
View raw message